Exchange 2010: Cannot Disable or Delete Mailbox


If you end up with message Action ‘Disable’ could not be performed on object ‘name’ along with “Active directory response: 00002098: SecErr: DSID-03150BB9, problem 4003 (INSUFF_ACCESS_RIGHTS), data 0”, there is an explanation and solution for this issue.

image

 

Is the active directory account for the Mailbox disabled? If yes, Mailbox is probably lost permission on SELF account. I would recommend enable the Active Directory account to disable or delete the mailbox.

Now the real explanation would be the account Exchange Trusted Subsystem don’t have permissions for the account to remove the Exchange attributes. It may be due the permissions are NOT inheriting to the user account.

The solution is to do the two things.

1. Give Exchange Trusted Subsystem  account Full Control over the User account

  • Open Active Directory Users and Computers console
  • Click View –> Advanced Features
  • Find the User account and double click to open the properties.
  • Click on Security Tab
  • Select Exchange Trusted Sub System and check the box for Full control permission.

image

 

2. Enable permission In-heritance

  • On the Security tab on user account properties (see above picture), click on Advanced button
  • Check the box for image

Wait for Active Directory Replication to happen or trigger manual replication between servers and sites. Try disable or delete operation again on the same mailbox.

If that works for you, reply “Yay!” for me here. Smile

Advertisements

18 thoughts on “Exchange 2010: Cannot Disable or Delete Mailbox

  1. Thanks, was having issues adding send as permission and also creating a new mailbox to an existing user. getting the above error. In the second case the user account didn’t have the Exchange Trusted Subsystem account in the Security tab at all.
    All working now.
    Dan

  2. Yay! I was going to delete a users account and re-add them because I could not get their Cell phone to send/receive emails…. SO I tried to delete the account and got the error as described above. After applying this fix I decided to try setting up the users email account on my phone IT WORKS…. THANKS!!!!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s